Cyrus imapd, DB4, RH 9.0 and NPTL

grenoml grenoml at
Tue Apr 22 14:43:25 EDT 2003

  You may want to take a look at this Redhat bug:

--- Mobeen Azhar <moby at> wrote:
> On a RH 9.0 system, up2date upgraded glibc from
> glibc-2.3.2-11.9.i386.rpm to
> glibc-2.3.2-27.9.i386.rpm.  Now it appears that anything applications
> that
> use POSIX mutexes are broken (only db4 so far affecting rpm and cyrus
> imapd).
> I was able to get rpm to work by doing a --rebuildb.
> Cyrus imapd will still not work.  I saw that any places in Cyrus
> imapd
> trying to use db4 would break.  So, I downloaded
> db4-4.0.14-20.src.rpm and
> tried to do a rpmbuild on it.  Lo and behold, while doing rpmbuild,
> the
> build bombs during the configure phase complaining about POSIX mutex
> support
> not being found.  Looking at the spec file, I see that this requires
> support.  I though that NPTL support was shipped with RH 9.0.  Is
> this true?
> If so, does updating glibc from 2.3.2-11.9 to 2.3.2-27.9 break it?
> I am going to edit the db4 spec file and take out the
> --enable-mutexes
> option from configure to see if then I can get a good build of DB4
> and
> whether that will take care of the DB4 problems that Cyrus imapd is
> complaining about.  Anyone have any thoughts on NPTL in RH 9.0 as
> regards
> DB4 and whether the glibc update mentioned above break NPTL or not?
> Thanks in advance for any help,
> --Moby
> They that can give up essential liberty to obtain a little temporary
> safety
> deserve neither liberty nor safety.  -- Benjamin Franklin
> First they came for the Jews and I did not speak out because I was
> not a
> Jew.
> Then they came for the Communists and I did not speak out because I
> was not
> a Communist.
> Then they came for the trade unionists and I did not speak out
> because I was
> not a trade unionist.
> Then they came for me and there was no one left to speak out for me.
> --  Pastor Martin Niem�ller 

Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo

More information about the Info-cyrus mailing list