Cyradm authentication failure

Oliver Sommer oliver at
Thu Apr 24 10:25:31 EDT 2003

> Hi,Oliver,
>  Thanks for your reply.
>  My Cyrus-sasl was configured only supports PLAIN and LOGIN.So ,I tried
> --auth login and --auth plain. I got the same error message after I inputed
> "cyradm --user cyrus -auth login" attempted to login.
> >>Login failed: authentication failure at
> >> /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Cyrus/IMAP/Admin.
> >>pm line 114 cyradm: cannot authenticate to server with login as cyrus
> But ,in the auth.log, This line disappeared.
> >>>>Apr 24 20:25:51 server perl: No worthy mechs found
> and ,after I ran "cyradm --user cyrus -auth login",the application seemed
> to  be hold ,no new logs.

my version of cyradm has a very strange behaviour at startup. maybe this is 
the same in your case(it sounds like).
I enter the commandline
cyrus --user cyrus --auth LOGIN localhost    	[hit enter]
then nothing happens, but the program doesn't quit.
actually it prompts me to enter the passwd, but the "enter password" prompt is 
not written out. nothing is written out. 
so I just wait 1 sec(for perl to load etc), then I enter the cyrus passwd and 
I am logged onto the server.

try this. imagine the cyradm program prompting for a passwd.

good luck!

More information about the Info-cyrus mailing list