Upgraded cyrus and I broke timsieved

Brian brianb at sboss.net
Fri Dec 6 10:27:07 EST 2002

Upgraded from HMH's cyrus21 2.1.9-6 to 2.1.10-5 after adding the
appropriate lines to my sources.list for Henrique's backports on Debian
Woody.  After migrating to skiplist, cyrus worked great except for sieve
which no longer sees any authentication methods.  Sieve worked fine
before, I don't understand what I did wrong.  Nothing in the logfiles that
I can see.  Pure Debian Woody system (nothing added that isn't a package).
 Based on the information below, can anyone give me any insight as to what
I've accidently broken?

kudzu:/var/tmp# sieveshell -u brianb -a brianb localhost
connecting to localhost
unable to connect to server at /usr/bin/sieveshell line 174.

kudzu:/var/tmp# sivtest -u brianb -a brianb localhost
S: "IMPLEMENTATION" "Cyrus timsieved v2.1.10-Debian-5.woody0"
S: "SIEVE" "fileinto reject envelope vacation imapflags notify
subaddress relational regex" S: OK
Authentication failed. generic failure
Security strength factor: 0
NO "Expected a command. Got something else."
NO "Expected a command. Got something else."
OK "Logout Complete"
Connection closed.

The packages that I have installed that pertain to cyrus are as follows:

ii  cyrus21-admin  2.1.10-5.woody
ii  cyrus21-client 2.1.10-5.woody
ii  cyrus21-common 2.1.10-5.woody
ii  cyrus21-docs   2.1.10-5.woody
ii  cyrus21-imapd  2.1.10-5.woody
ii  cyrus21-pop3d  2.1.10-5.woody
ii  libsasl-gssapi 1.5.24-15
ii  libsasl-module 1.5.27-3
ii  libsasl2       2.1.9-5.woody1
ii  libsasl7       1.5.27-3
ii  sasl-bin       1.5.27-3
ii  sasl2-bin      2.1.2-2

My imapd.conf and cyrus.conf are as follows:

configdirectory: /var/lib/cyrus
defaultpartition: default
partition-default: /var/spool/cyrus/mail
partition-news: /var/spool/cyrus/news
newsspool: /var/spool/news
altnamespace: no
unixhierarchysep: no
admins: cyrus
allowanonymouslogin: no
popminpoll: 0
autocreatequota: 0
umask: 077
sendmail: /usr/sbin/sendmail
sieveusehomedir: false
sievedir: /var/spool/sieve
hashimapspool: true
allowplaintext: yes
sasl_mech_list: PLAIN LOGIN
sasl_minimum_layer: 0
sasl_pwcheck_method: saslauthd
sasl_auto_transition: no
tls_cert_file: /etc/cyrus/ssl/cyrus.pem
tls_key_file: /etc/cyrus/ssl/cyrus.pem
tls_imap_cert_file: /etc/cyrus/ssl/cyrus.pem
tls_imap_key_file: /etc/cyrus/ssl/cyrus.pem
tls_pop3_cert_file: /etc/cyrus/ssl/cyrus.pem
tls_pop3_key_file: /etc/cyrus/ssl/cyrus.pem
tls_sieve_cert_file: disabled
tls_sieve_key_file: disabled
tls_ca_path: /etc/cyrus/ssl
tls_session_timeout: 1440
tls_cipher_list: TLSv1:SSLv3:SSLv2:!NULL:!EXPORT:!DES:!LOW:@STRENGTH
tls_sieve_require_cert: false
lmtpsocket: /var/run/cyrus/socket/lmtp
idlesocket: /var/run/cyrus/socket/idle
notifysocket: /var/run/cyrus/socket/notify
	recover		cmd="/usr/sbin/ctl_cyrusdb -r"
	delprune	cmd="/usr/sbin/ctl_deliver -E 3"
	tlsprune	cmd="/usr/sbin/tls_prune"
	imap		cmd="imapd -U 30" listen="imap" prefork=0 maxchild=100
	imaps		cmd="imapd -s -U 30" listen="imaps" prefork=0 maxchild=100
pop3		cmd="pop3d -U 30" listen="pop3" prefork=0 maxchild=50
	pop3s		cmd="pop3d -s -U 30" listen="pop3s" prefork=0 maxchild=50
	lmtpunix	cmd="lmtpd" listen="/var/run/cyrus/socket/lmtp" prefork=0
  	sieve		cmd="timsieved" listen="localhost:sieve" prefork=0
	notify		cmd="notifyd" listen="/var/run/cyrus/socket/notify" proto="udp"
	checkpoint	cmd="/usr/sbin/ctl_cyrusdb -c" period=30
	delprune	cmd="/usr/sbin/ctl_deliver -E 3" at=0401
	tlsprune	cmd="/usr/sbin/tls_prune" at=0401


More information about the Info-cyrus mailing list