saslauthd w/ ldap issues continued

karthikeyan knagalin at
Wed Sep 13 23:40:37 EDT 2006

if you are using postfix as the MTA, check is it chroot in enabled in


AJ wrote:
> I have been trying to get saslauthd working w/ ldap.
> I am trying to authenticate via the user's mail attribute as opposed  to 
> their uid attribute.  Here is my saslauthd.conf file.
> ldap_servers: ldap://
> ldap_search_base: dc=Users,dc=domain,dc=com
> ldap_filter: mail=%u
> ldap_auth_method: bind
> ldap_use_sasl: no
> SASL version is 2.1.19 from RHEL 4 update 4
> This works w/ testsaslauthd for usernames such as test at
> When i use imtest from cyrus imapd, it does not work.  I have tried  
> running saslauthd with and without the -r flag and the result is the  
> same.  It seems that saslauthd is stripping off the domain part either  
> way.
> On the ldap server i see this:
> SRCH base="dc=Users,dc=domain,dc=com" scope=2 filter="(mail=test)" 
> attrs="dn"
> Notice under filter it does not say test at domain, but when I run  
> testsaslauthd it does.
> Any ideas here?

More information about the Cyrus-sasl mailing list