evil build problems with cyrus-sasl-2.1.21

Bernard Leak bernard at brenda-arkle.demon.co.uk
Fri Sep 1 16:39:27 EDT 2006

Dear List,
	    several of my problems were my own fault.  I'd managed to
delete some important stuff from /usr/share/aclocal* . Then I ran into
the missing CMU definitions, and after some threshing around found the
useful but not very conspicuous comment about using aclocal -I cmulocal,
not just aclocal.  So far so good.  However, I'm STILL not picking
up the definitions of
These are substituted in the version of 'configure' actually supplied,
but it's not at all clear how that was generated from configure.in
(nor even that it WAS).  The macros are defined in sasldb.m4, but when
and how does that file get scanned for the m4 macro definitions inside
it?  As far as I can tell, it doesn't.  I can't see how even another
old version of autoconf - I'm using 2.60 - would solve the problem,
though I don't really understand the autotools chain so well that I
can be certain.

    Others have said (without being specific) that the current autotools
won't regenerate the files properly, which MIGHT be what I'm seeing,
or something else falling under the same description.

    I only have so much life and time to spend on this.  Can someone
cast some light?
                                        Bernard Leak.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cyrus-sasl-2.1.22-bl12-1.patch
Type: text/x-patch
Size: 12555 bytes
Desc: not available
Url : https://lists.andrew.cmu.edu/mailman/private/cyrus-sasl/attachments/20060901/4e72796c/cyrus-sasl-2.1.22-bl12-1.bin

More information about the Cyrus-sasl mailing list