AUTH failure (LOGIN): no mechanism available (-4) SASL(-4): no mechanism available: checkpass failed

Rob Szarka szlists at
Tue Jun 13 08:55:40 EDT 2006

At 06:34 AM 6/13/2006, you wrote:
>So I’ve created a config-file for sendmail: 
>/opt/csw/lib/sasl2/Sendmail.conf, which contains
>pwcheck_method: shadow (sendmail was running as 
>root, meaning that it should be able to read /etc/shadow)
>I’ve tried changing to “pwcheck_method: 
>saslauthd” and starting /opt/csw/sbin/saslauthd, 
>with the params –a shadow (or –a pam) –V to see 
>if that would worked better, but no
 (I’ve also 
>checked that saslauthd is running as root, to be able to read the /etc/shadow)

I think "pwcheck_method: saslauthd"  is what you 
want. But are you sure that /opt/csw/lib/sasl2 is 
the correct location for Sendmail.conf? (I don't 
know about Solaris, but on FreeBSD it's located in /usr/local/lib/sasl2.)
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Cyrus-sasl mailing list