authdaemond as mechanism on Solaris 8

Stefan Lindén stefan at
Wed Dec 6 16:28:38 EST 2006

I tried to compile the SASL with –with-authdaemond on Solaris 8. THe  
compilations worked fine but I cannot get testsaslauthd to  
authenticate me.
If I run saslauthd I get the following:

saslauthd 2.1.22
authentication mechanisms: sasldb getpwent pam rimap shadow

No authdaemond there….!

What am I doing wrong here? I tried to start saslauthd with every  
single mechanism without any luck.

Like this:

saslauthd -a pam
saslauthd -a sasldb

When I try testsaslauthd:

/usr/local/sasl2/sbin/testsaslauthd -u tom at -p blabla
0: NO “authentication failed”

And the log says:

Dec 6 23:18:06 XXXX saslauthd[6464]: [ID 285309 auth.error] main : no  
authentication mechanism specified
Dec 6 23:19:47 XXXX saslauthd[4351]: [ID 219349 auth.debug]  
pam_unix_auth: user tom at not found
Dec 6 23:19:47 XXXX saslauthd[4351]: [ID 544118 auth.debug] DEBUG:  
auth_pam: pam_authenticate failed: No account present for user
Dec 6 23:19:47 XXXX saslauthd[4351]: [ID 285309] do_auth :  
auth failure: [user=tom at] [service=imap] [realm=] [mech=pam]  
[reason=PAM auth error]

I cannot enable the authdaemond-mechanism no matter what I try.

Any ideas?

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Cyrus-sasl mailing list