imapd(?) of 3.0.2 not working here [was: Re: Had problems upgrading to 3.0?]

Stephan Lauffer lauffer at
Wed Aug 2 03:29:09 EDT 2017

Dear Nicola,

Zitat von Nicola Nye <nicola at>:
> If this was you, and you want some help upgrading, send through some  
> more information. (There's no "double free" string anywhere in the

It wasn't me but I have mystify problems with 3.0, too (3.0.1 and  
3.0.2 tested). I have build my rpms in the open build system for some  
suse/sles distributions and atm I am testing them on an opensuse leap  

My problem is that - I guess the imapd process - can not get mailbox  
informations. I guess the cyradm and perl tools are ok. Attached is a  
"strace -f" of the imapd process which is connected by my cyradm and  
the command there was just a simple "lm".

I see there no errors, no problems in the strace.

I see no errors/problems in the mailboxes.db (attached, too). The  
command "ctl_mboxlist -d" is working here.

I have no problems with 2.5.10, 2.5.11 builds.

My spec (based on the work of suse) you can find here:

My non-default config options are:

/usr/lib/cyrus/bin/cyr_info conf
admins: cyrus
allowplaintext: yes
altnamespace: no
configdirectory: /var/lib/imap
defaultpartition: default
duplicate_db_path: /var/lib/imap/deliver.db
hashimapspool: yes
ptscache_db_path: /var/lib/imap/ptscache.db
sievedir: /var/lib/sieve
statuscache_db_path: /var/lib/imap/statuscache.db
syslog_prefix: cyrus
tls_client_ca_dir: /etc/ssl/certs
tls_sessions_db_path: /var/lib/imap/tls_sessions.db
unixhierarchysep: no
sasl_auto_transition: no
sasl_pwcheck_method: saslauthd
partition-default: /var/spool/imap

For me it doesn't looks like a config failure. Maybe a error in the  
combination of my configure options? Maybe a problem with my  
  --libexecdir,  --binddir,  --sbindir settings? They are temporary...  
I will change them later on. Atm I just tried to stay closely to older  
suse paths of some binaries.

Sidenote: I guess perl/cyradm is ok because I have set up a fedora 26,  
too. There is a working 3.0.2 (packed by Jason, in CC). I used the  
cyradm of this fedora and connected to the cyrus imapd of my 3.0.2 on  
openSUSE leap 42.3 with the same result/problem. This is the reason  
why I guess the problem is deeper somewhere in imapd (and others) of  
my build.

And hints or ideas?

Liebe Gruesse, with best regards
Stephan Lauffer

Pedagogical University Freiburg - Germany
Fon/ Fax: +49 761 682 -559/ -486
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: imapd-strace-listmailbox.txt
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mailboxes.db
Type: application/octet-stream
Size: 1200 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5962 bytes
Desc: S/MIME-Signatur
URL: <>

More information about the Cyrus-devel mailing list