Bron Gondwana wrote: > > How do you feel about: > > if (a) function_one(a); > else function_two(); > This is hard to read. My rule is one liner only if it's really a one liner. Otherwise: if (a) { function_one(a); } else {function_two();} is a reasonable compromise between brevity and readability.