Ready for 2.3.10?

Rudy Gevaert Rudy.Gevaert at
Mon Oct 8 05:50:43 EDT 2007

Ken Murchison wrote:
> Folks,
> I *think* 2.3.10 is just about ready.  Does anyone feel that there are 
> any showstopper bugs that need to be addressed before I make a release 
> candidate?

To help a bit, I have tried build from CVS.

I checkout out the trunk, and I thought I should sh SMakefile.  That 
complains because it doesn't have the 'sys' command.  I commented that 
out, and then it complained about my perl version.

I went to cyrus and cyrus-devel archives, and found a message from Bron 
that said something like, get the aclocal part and autoconf and 
autoheader parts out.

So I  ran:
aclocal -I cmulocal

(Do I actually need this?  When I
./configure ...
make depend
make all CFLAGS="-O2 -g"

It then complained I didn't have 'yacc', I'm doing this in the same 
chroot that compiled my 2.3.7 and 2.3.9 from tarball.  Why does it need 
yacc now?   Anyway I installed bison.

Now it breaks on:

gcc -L/usr/lib -Wl,-rpath,/usr/lib -L/usr/lib/ -Wl,-rpath,/usr/lib/  -o 
sievec sievec.o libsieve.a ../lib/libcyrus.a ../lib/libcyrus_min.a 
libsieve.a -lsasl2   -lresolv  -lresolv  -L/usr/lib/ 
-Wl,-rpath,/usr/lib/ -ldb-4.3 -lssl -lcrypto  /usr/lib/libcom_err.a
libsieve.a(script.o)(.text+0x311): In function `sieve_script_parse':
/tmp/cyrus-imapd/sieve/script.c:175: undefined reference to `yylineno'
libsieve.a(sieve.o)(.text+0x1518): In function `yyparse':
/tmp/cyrus-imapd/sieve/ undefined reference to `yylex'
libsieve.a(sieve.o)(.text+0x1555): In function `sieve_parse':
./sieve.y:677: undefined reference to `yyrestart'
libsieve.a(sieve.o)(.text+0x15b6): In function `yyerror':
./sieve.y:694: undefined reference to `yylineno'
libsieve.a(addr.o)(.text+0x669): In function `addrparse':
/tmp/cyrus-imapd/sieve/ undefined reference to `addrlex'
collect2: ld returned 1 exit status
make[1]: *** [sievec] Error 1
make[1]: Leaving directory `/tmp/cyrus-imapd/sieve'
make: *** [all] Error 1

Actually I don't think I need the m4 files in the cmulocal dir, it 
cmulocal stuff.  But if I only do:

check out cvs

pimp:/tmp/cyrus-imapd# autoconf error: possibly undefined macro: AC_DEFINE
       If this token and others are legitimate, please use m4_pattern_allow.
       See the Autoconf documentation.
./configure ...
./configure: line 5662: CMU_SOCKETS: command not found
./configure: line 5666: syntax error near unexpected token `getaddrinfo,'
./configure: line 5666: `IPv6_CHECK_FUNC(getaddrinfo, 

So I then tried with a ugent directory that only contained the macro's 
that where needed.  But make all still stops at the same place as above.

Any hints would be appreciated to compile from CVS.

Thanks in advance,


-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Rudy Gevaert          Rudy.Gevaert at          tel:+32 9 264 4734
Directie ICT, afd. Infrastructuur ICT Department, Infrastructure office
Groep Systemen                    Systems group
Universiteit Gent                 Ghent University
Krijgslaan 281, gebouw S9, 9000 Gent, Belgie     
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --

More information about the Cyrus-devel mailing list