A couple of goodies

David Carter dpc22 at cam.ac.uk
Fri Aug 10 11:51:13 EDT 2007

On Fri, 3 Aug 2007, Ken Murchison wrote:

> I applied Bron's patch, with a few small tweaks (hierachy -> hierarchy,

Oops, sorry: my fault.

> changed some of the option caching) to my sandbox.

Is your cyr_expire "-D" option keyed on file suffix or a stat() against 
the cyrus.header file? I guess that file suffix will be faster, but stat() 
may be more reliable if the naming conventions change at a later date.

> A couple of thoughts before I commit this code:

> - Should we actually have the LIST code explicitly suppress DELETED, or 
> should we augment the ACLs of DELETED mailboxes to include "-anyone l", 
> which will hide them from non-admins?

This would certainly be a more natural Cyrus way of doing things if it was 
easy. I was aiming for the simplest patch that I could get away with.

> - Should DELETED be its own namespace?

The only people who can see DELETED are admins, who automatically get the 
internal namespace. Is there any advantage in adding another namespace?

> - Should the "delete_hierarchy" option be changed to "deleteprefix" to 
> match up with "userprefix" and "sharedprefix"?

If you were going to add another namespace, then definitely yes.

As it stands the argument would seem to be consistency with existing names 
used for other purposes. We have a number of *prefix names, but no 
*_hierarchy names, so I guess my vote would be for deleteprefix.

David Carter                             Email: David.Carter at ucs.cam.ac.uk
University Computing Service,            Phone: (01223) 334502
New Museums Site, Pembroke Street,       Fax:   (01223) 334679
Cambridge UK. CB2 3QH.

More information about the Cyrus-devel mailing list