Since updating to 2.4.10: Mailbox has an invalid format

Marc Muehlfeld Marc.Muehlfeld at
Thu Sep 1 02:57:46 EDT 2011

 > imap[11591]: IOERROR: refreshing index for user.muehlfeld.IMGM_Extern.GbR: 
 > imap[11591]: IOERROR: locking index user.muehlfeld.IMGM_Extern.GbR: Mailbox 
has an invalid format

After an horrible day of many many broken mailboxes (after upgrading from 
2.3.16 to 2.4.10) and as same many repairs, I found the solution: I moved 
/var/spool/imap from XFS to Ext4. I've done this 36h ago and since that moment 
no mailbox got broken again.

If someone else is having the same problem - this are the steps I have done:
- Create a new volume with Ext4 and mount it
- Shutdown Cyrus
- Run "reconstruct -O -r user.*" as user cyrus to repair all broken mailboxes. 
(I run it twice, just to be sure, that everything is fine. :-))
- Copy the content from /var/spool/imap to the new Ext4 volume.
- Mount the Ext4 volume to /var/spool/imap (don't forget to change your 
/etc/fstab entry!)
- Because I'm paranoid, I run the above reconstruct again - now on the Ext4 
- Started Cyrus.

My server is running Scientific Linux 6.1 (x86_64). All software was installed 
from the repository (just cyrus is selfcompiled). All kernel settings are also 
left on their default.


More information about the Info-cyrus mailing list